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[bookmark: _Toc443998221]An introduction to the TaxEditor
The TaxEditor is the desktop application used to edit data stored in the Common Data Model (CDM) Community Store. It edits data in either a remote source or a local data source. 

For the installation, you should have 1 GB free disk space. Please start the installation program (Install.bat) on the Memory stick[footnoteRef:1].  [1:  In addition to the EDIT-Workshop folder, the batch file creates a folder “.cdmLibrary” in your user directory, which contains your locally saved data and the local program preferences you selected. In your user directory you normally have full rights (read, write, execute), which is necessary for program execution. 
Program updates can be downloaded from http://cybertaxonomy.eu/download/platform/taxeditor/ for different operating systems – for Windows select one of the last two (for 32 bit and 64 bit Windows, respectively).  ] 


[image: ]When finished, you should have a folder “EDIT-Workshop” in your MyDocuments folder:



The Handout.. document is this document – it is a good idea to open it so that you can copy links and text from it. 
The folder EDIT Taxonomic Editor contains the program files, don’t worry about that one.
The folder TaxEditor contains files we need when learning about that program – best to open it now.
The folder Xper contains the Xper program and demo files, we’ll look at that later. 

and a desktop Icon should have been created to start the TaxEditor. 

We will start working with a completely empty database:  

Go to the menu and choose General -> Connect. In the following dialog choose the CDM Server	 
“edit-WS” and the CDM Instance “demo_##” (where ## stands for the group number issued to you in the workshop). 

The Login is “admin” and the Password “00000”.

[image: ]


Now you are ready to try out the TaxEditor!

[bookmark: _Toc443998222]The User Interface
The user interface of the TaxEditor is highly configurable. However, we will mostly use a standard configuration as depicted in the following figure:
[image: ]
In the following, we will call these windows (“views”) Taxon Navigator, Name Editor, Factual Data view and Details view. The individual windows can be closed, opened, sized and arranged according to your needs and preferences. 
For example, when you start a fresh installation of the TaxEditor you have the Taxon Navigator on the left. [image: ]Close it by clicking on the X in the tab: 


[image: ]To open it again, go to the menu: Window -> Show View -> Taxon Navigator. 


It works this way for most of the windows that are available in the TaxEditor. 
[image: ]As in other Windows applications, you can enlarge or minimise a window with the symbols on the top right.
Try to maximise, minimise and restore the Taxon Navigator window.
[image: ]You can move windows with the mouse. Try moving the (empty) Details view. Grab it with the mouse pointer at the top and move it around. You can make it into a tab in an existing window by dragging it onto a tab in that window. 
Try to restore the original screen, with the Taxon Navigator to the left, the (empty) Name Editor centre top, the Factual Data centre bottom and the Details to the right. 
On the top right of the TaxEditor Interface, you can choose a Perspective. These are pre-arranged windows for special purposes. We will stick to the Taxonomic perspective for the time being. 
When you exit the TaxEditor using the menu (General -> Exit), your last window settings will be preserved. 


[bookmark: _Toc443998223]Basics: creating and saving a record
For a first demonstration of the capabilities, we will create our own classification, add a taxon and have a look at what happens in the Interface. 
[image: ]Right click on My Classification in the Taxon Navigator, -> Edit, and change the Label from “My Classification” to “Grupo#” -> Finish.






[image: ]
Add a taxon: Right click on your new classification in the Taxon Navigator 
-> New -> Taxon
Enter “Agave mexicana Lam.” -> Finish. 
We had asked to have the new taxon opened in the Name Editor, and that’s what happens, it appears in the central Name Editor window. It was automatically saved in the database. 
[image: ]
[image: ]NB: A leading asterisk indicates that the record has not been saved. Always use Ctrl-S or the Save button after making changes.

[bookmark: _Toc443998224][image: ]Basics: Details and Caches
Have a look at the Details window to the right on your screen.
Note that the name has actually been parsed into its data elements. 
First you will note that there is a certain duplication of data elements. There are so-called “Cache” elements and the broken down data elements. 
[image: ]With “good data”, the “Caches” are texts that have been put together from other, more “atomized” elements (like in this case). 
You cannot enter data into the cache fields, as long as you did not open the lock beside the cache. 
[image: ]Try to open the Cache field in the Name section. 
The “atomized” data that are not used to calculate the cache are than highlighted. Try and change the name in the Cache. 
[image: ]Save and have a look at your data portal: http://ws1.cybertaxonomy.org/dataportal/demo_##/
(text copied from Caryophyllales.org, ignore, please)
The Output always represents the Cache data, even when atomized data exist.
We can use the cache fields to store preliminary unstandardized data (as they often result from data imports). 
Switch back the padlock to its locked position. 
[image: ]The Cache record will be overwritten by the concatenated value. 
Don’t forget to Save! 



[bookmark: _Toc443998225]Basics: Editing and choosing data in the Details view
[image: ]
Throughout the TaxEditor, there are a few further symbols for specific functions. Let’s try these in the Authorship section of the Details window. 

[image: ]
[image: ]The folder button opens a search interface for existing data items. If you don’t find it, you can enter a new one. Try to change the author from “Lam.” to “Hernández”. 
You will have to create a new Person for that: 
Enter the “Abbreviated Title (= Name) and watch out for the cache setting!)
[image: ]The Edit button directly opens the entry and lets you change it. Use it with caution: with full rights the changes here will change all occurrences of the entry in the database! For example, if you change “Lam.” to “Hernández” using this function, all names in the database with author Lam. will be changed to author Hernández.
[image: ]
The garbage bin button will remove the selected item from this record – it will not delete it from the database. Try to remove and put it back using the Browse existing button.
[image: ]Further symbols: 
[image: ]In the Factual Data window you find these + / - symbols. They work similarly to the triangles  in the Taxon Navigator,                           opening and closing subordinate items. 

When you find a + symbol after an entry, it means that there are additional data. 


[bookmark: _Toc443998226]Basics: Factual Data
To be able to add “Factual Data”, you have to have a (saved!) Taxon selected in the Edit window. 
[image: ][image: ]With a right click in the white space of the Factual Data window you can add a factual dataset. 
Note that you can add more than one factual dataset (for example, if you want to add data from different floras that all use the same taxon concept). 
[image: ]Also note that the TaxEditor calls the entire factual dataset a “Description”. 
(And don’t forget to safe!)
[image: ]Within the “Description”, you can add different Features. 
Right click on the Description-line for a selection of preconfigured and user defined features. 





Try Common Name to see that the Details window now displays the specific data for a common name: the name itself, its language, area of use, references and there might be also a recording of its pronounciation (Media). 
[bookmark: _Toc443998227]TaxEditor: The Name Editor, Nomenclature and Taxonomy
To show you the taxonomic workflow with the TaxEditor we will add the information of an actual taxonomic paper. Open the paper from the “docs” folder of the workshop (Korotkova et al 2010 Pfeiffera_Lymanbensonia_ppTax.doc).

For the workshop we provide you with a copy of our Caryophyllales Genera dataset. 

Go to the General Menu and choose Connect.
In the following dialog choose the server “edit-WS I” and the datasource (CDM Instance) “caryophyllales_demo_##” (where ## stands for the group number issued to you in the workshop). 

The user is “admin” and the password “00000”. 

Next open the following URL in your Internet Browser: http://ws1.cybertaxonomy.org/ 
and open your Data Portal caryophyllales_demo_##. You don’t have to log in here. 
You can follow your changes in the database directly in the dataportal. 
[bookmark: _Toc443998228]Add a new name to Lymanbensonia Kimnach
To add L. incachancana as a child taxon to the genus Lymanbensonia, go to the Taxon Navigator, select the genus, open the menu with a right click and choose -> New -> Taxon
[image: ]Copy the entire name (including authors) from the paper to the field New Taxon and click Finish 
-> a new taxon appears and the name will be automatically atomized.
[image: ]This is a new combination in the present article, so add “in Willdenowia 40(2): 167. 2010” as the nomenclatural reference. Input may be a bit choppy as the program tries to parse it immediately. 
Please also add the names and the types of the other 3 species of Lymanbensonia, so that we have them available for the workshop: L. brevispina, L. crenata y L. micrantha. 
[bookmark: _Toc443998229]Adding a “sec. Reference”
[image: ][image: ]Have a look at the Details view on the right. In the Taxon section, the “Secundum” is a reference that defines the circumscription of the taxon. In our case this is the same article we are working with. Look under Browse existing            if the reference already exists. It does: Korotkova & al. (2010). 
Look under Edit         [image: ]if the reference is correct. It is, but the reference record is not properly atomised. Don’t worry about this now, we will have a look at references later.
[bookmark: _Toc443998230][image: ]Adding details to the authors
[image: ]Go to the Name section of the Details view and edit the authors.
Add the full names to the persons.
[bookmark: _Toc443998231]Check the nomenclatural reference citation
Go to the Nomenclatural Reference section in the Details view, check whether the reference is atomized correctly. 
[bookmark: _Ref443076967][bookmark: _Toc443998232]Add a synonym, its reference citation and the type
In the Name Editor window, enter a carriage return right after the full name and citation of the taxon. 
Copy the basionym Rhipsalis incachacana including its Author and nomenclatural citation from the paper to the new line in the Name Editor.  
For some reason the reference title cannot be parsed. Go to the Nomenclatural Reference section in the Details view and enter the article.
Go to the Type Designations section of the Details view and add the specimen information from the paper (for now we do not atomize the data, atomization will be done later). 
The synonym is a basionym of the correct name. In the Name Editor window, grab the synonym and drag it onto the correct name. The symbol now indicates the homotypic relationship of the two names. 
Right click on the basionym and select Set as basionym for this homotypic group.[footnoteRef:2]  [2:  Please ignore the Synonym Relationship text given in the Details view, this will be removed in one of the next versions. The interface will then also allow the direct handling of replaced synonyms and nomina nova in the homotypic group. ] 

[bookmark: _Toc443998233]Change the Classification – add a tribe
In the Paper, Korotkova & al. describe a new Tribe, Lymanbensonieae.
Add this tribe under Cactaceae (best to copy from here): 
Lymanbensonieae N.Korotkova & Barthlott in Willdenowia 40(2): 166. 2010
Add the (invalid) synonym Calymanthieae from the paper (go to the Nomenclatural Status section of the Detail view to add the status). 
In the Taxon Navigator, grab the genus Calymmanthium and drag it onto Lymanbensonieae. Do the same for Lymanbensonia. 

[bookmark: _Toc443998234]Change the status of a name
Lets assume that we have concluded that L. incachacana is actually a synonym of L. micrantha.
Right click on L. incachacana in the Taxon Navigator. Select Change accepted taxon to synonym and select the accepted name. 
Have a look at L. micrantha now. In the Name Editor window, right click on L. incachacana. You can reverse your decision and turn this into a taxon again by selecting Change To -> Accepted Taxon.


[bookmark: _Toc443998235]TaxEditor: Unstructured factual Data
These are data that mainly consist of a single piece of text, such as a common name or a summary statement on something. This may be accompanied by some contextual information like language or scope (for example, the language of a common name and the geographical area where it is used). This contextual information may be standardised in a vocabulary which is given in a selection list (e.g. languages). All factual data can be referenced individually to a source. 
[bookmark: _Toc443998236]Add factual data
Use again the paper about Lymanbensonia to copy and paste factual data from the paper. 
Open the genus Lymanbensonia in the Name Editor. Look at the Factual Data window. The genus already has a factual dataset (“Description”) containing the notes given in the publication, so we don’t need to add a new one. 
Right click on Description in the Factual Data view -> New -> Description (the latter here meaning the actual textual description of the genus). 
Copy and paste the description text from the article into the text field in the Details view. 
Add Korotkova & al. 2010 as the Reference. 
Proceed to add the general distribution, etymology and the key from the paper using the same workflow. 
Have a look at the data in your data portal. You can use HTML formatting in the free texts: for example, if you start a species name in the key with <i> and end it with </i>, it will show up as italics in the portal. 
[bookmark: _Toc443998237]Adapt the vocabulary of a selection list
Use the Taxon Navigator to go to Caryophyllaceae and Arenaria and try to add a common name 
Right click on Description in the Factual Data view -> New -> Common Name
In the Details view -> click on the Language -> the system provides a large number of languages! Normally only a handful is really needed.
Go to the menu -> Windows -> Preferences and choose your language preferences (see below), for example Spanish, English, German, French.
[image: ]
Go back to the common names and add for example Spanish “arenaria”, English “sandwort”, German “Sandkräuter”, French “sablines”.
You could add a media file to produce the pronunciation if you had it. This may come in handy in an ethnobotanical context, same as the possibility to define the geographical area where this name is used. 


[bookmark: _Toc443998238]TaxEditor: Complex factual data
In contrast to unstructured descriptive data, complex descriptive data are structured in themselves, for example by being part of one or more hierarchies of terms and classes (e.g. geographical areas), by having other dependencies (e.g. the derivation history of a DNA sample), or by special features such as links to other data items (e.g. in semi-structured keys).  
[bookmark: _Toc443998239]Area distribution[footnoteRef:3] [3:  Please be patient during data input, this process has not yet been optimized for performance. ] 

Distribution by geographical areas is based on catalogues that may be created and maintained in the Term Editor (we’ll have a look at that later). 
Area input is also handled through the Factual Data window. 
Right click on Description in the Factual Data view -> New -> Distribution (Area)
In the Details view open the selection dialog for the area. 
Lymanbensonia is native in Peru and Bolivia according to the following article: 
Ibisch P. L., Kessler M., Nowicki S. & Barthlott W. 2000: Ecology, biogeography and diversity of the Bolivian epiphytic cacti, with the description of two new taxa.– Bradleya 18:  2 – 30.
For variety, we’ll also add that it is cultivated in Mexico. 
Have a look at the map in the Details view when you click on Distribution (areas) in the Factual Data window. This should also be visible in the Portal. 
[bookmark: _Toc443998240]Images
Images are not stored directly in the CDM, so they have to be available under an Internet address (URL) to become part of CDM data. Since images can be attached to a number of database objects (Taxa, Specimens, morphological characters, etc.), they are handled differently. 
To add an image to a taxon, first open the respective taxon in the Name Editor window. Next you go to the menu, Windows – ShowView – Media. This opens the Media view. Select the taxon and right click on the empty space within the Media view -> New Image Gallery.
Select the empty media item and add your data in the Details view.   
For example, you can add images from flickr: https://www.flickr.com/search/?text=Lymanbensonia 
Copy the URL of the flickr image to the URL field in the Details view, and the image’s metadata in the other respective fields. 
[bookmark: _GoBack]This may not work if you are not a Flickr member; alternatively, try the following URL: 
Dianthus deltoides, Berlin, Germany, W.-H. Kusber, CC-BY-SA http://media.bgbm.org/erez/erez?cmd=get&src=specimentool/plants/dicots/Dianthus_deltoides_2014-09-21_whk_DE_Rehwiese_P1060030.JPG. 

[bookmark: _Toc443998241]Identification Keys
We had already introduced a key to the species of Lymanbensonia by simply copying and pasting the entire text of the key into a database field. This is of course a very unsophisticated way to proceed. The platform provides another possibility to enter and display keys.
Close your Name Editor and Media windows. 
In the menu, use Window -> ShowView -> Polytomous Keys to open the respective view. All such semi-structured keys that have been created in the database will be listed (none as yet). 
Right click in the empty area of the Window -> New. Enter the Title as “Key to the species of Lymanbensonia” and select Lymanbensonia as the Taxonomic Scope. 
In the Key Editor window, you can now sequentially add the Statements and their Alternatives; the leads will be added automatically in this case.
Have a look at your new key in the data portal. 
[bookmark: _Toc443998242]Specimens
The EDIT Platform is a software for taxonomic research and research results, it is not a collection management system. In contrast to the latter, as a rule only taxonomically scrutinised specimens are introduced into a Platform database (or at least it is the aim to have only such quality data present). These may stem from many different collections. The Platform also lacks typical collection management features such as loan management, curation details, etc.
In the underlying Common Data Model (CDM), specimens are treated as part of a derivation tree that may include various objects such as DNA- and tissue-samples, sequences, duplicate specimens, cultivated living specimens, etc. The tree is rooted in what we call a Field Unit, which is in our case the plant in the field with the respective collection event data.  All Derived Units can be traced back to the Field Unit. 
This is a rather complex structure since all these “units” can have various complex other data objects attached to them (images, morphological descriptions, etc.). Moreover, the specimen data themselves are far from simple (the ABCD standard lists hundreds of data items that can be used to characterise a specimen – and this does not include morphological descriptors). 
This long introduction serves to explain why there are several ways to add and edit specimens in the TaxEditor (and also to explain why some of them still need a bit of work on the software development side to make them user-friendly). 
The different possibilities for specimen data entry:
· As a type specimen: see section 2.5.
· Starting in the Factual Data view: see below
· Using the specimen Bulk Editor: see section 6.3.
· Using the Derivative Editor: see section 7.2.
· Via the Described Specimen function in the Details view of the Description in the Factual Data view: Sorry, work in progress, please do not use! 
Specimen entry starting in the Factual Data view
We want to enter the following specimen for Lymanbensonia crenata:  
Bolivia, La Paz, Prov. Sud Yungas, 39 de La Plazuela a La Paz, 16°38’S, 67°34’W, 2300m, 22.9.1995, Kessler 5663 (LPB).
Open Lymanbensonia crenata in the Name Editor. 
Right click on Description[footnoteRef:4] in the Factual Data view -> New -> Specimen.  [4:  If you don’t see a Description entry, add a new factual dataset by right clicking in the empty area of the Factual Data window and choose New).] 

In the Details view, click on the Browse existing button for Occurrence/Unit.
[image: ]Enter ? to check if the specimen has already been entered. 
If not, choose Create a new field unit/derived unit below. Enter the atomised data as depicted. 
Note that the country selection is somewhat slow, this is about to be fixed in the next version. 
If you copy the Latitude / Longitude fields from a text using geographical (NSEW-) coordinates, for the time being please pay attention that you get the straight quotes for minutes and seconds (not: ‘ and “).
You probably have to enter a new person for the Collector (just use the Title Cache field in this case) and a new Collection (use the Code field). 




[bookmark: _Toc443998243]TaxEditor: The Term Editor
The TaxEditor already comes with many terms and vocabularies, but for specific applications you may want to add new ones with the Term Editor. As an example we add a new feature for factual data[footnoteRef:5]. [5:  Again, please be patient during data input, this is a rarely used process and has not yet been optimized for performance.] 

Go to the menu, Window -> Term Editor -> Features
[image: ]A new window shows the vocabularies [Taxon-] Features and Name Features
right click on Features, -> New -> Defined Term
Edit the new defined term in the Details window. For example create a new feature “Uses as Food”.
Set Supports Text Data.
[image: ]



[image: ]As an example for quantitative Data add a new feature “Leaf Length”, select Supports Quantitative Data, and then you can add the recommended measurement unit and the statistical measures. 
[image: ]





Go back to the factual data view and see that the new features appear in the selection of features.
[bookmark: _Toc443998244]TaxEditor: The Bulk Editor
The Bulk Editor provides easy access to a list of objects of a given type, e.g. names, specimens, references, persons, etc. Here you can sort out or clean your data without having the entire context in view. 
Of course, similar as explained with the Edit button in the Details view, editing a record is inherently dangerous: For example, changing a person’s name will change all uses of that name (collector, bibliographic author, etc.). 
In the Bulk Editor, you can actually delete records (e.g. erroneously imported records) – provided that they have not been used in some context. 
Another important function is deduplication.
[bookmark: _Toc443998245]Persons and teams
A Person Team consists of several persons. Good practice is to create the Person records individually and then compose a team only if there are more than a single person, e.g. as author team of a taxon name. 
In imports (and sometimes in input) usually many entries are generated that refer to the same persons or teams. We will try to sort out some of the authors and teams in the Caryophyllales database. 
Go to Window -> Bulk Editor -> Persons and Teams, enter “D*” and search
Right click on any record, -> Show in -> Referencing objects. This will open the Referencing Objects view. Here you can see where and in which context the respective person name or team has been used. 
Deduplication: “D.Don” is repeated in the database. Look at the two records in the Details and Referenzing Objects views. Mark the second record as target for deduplication and the other one as candidate for deduplication and click deduplicate group. Watch the result in the Referencing Objects view.
You can go ahead and deduplicate those entries were a single person exists as person and as team. 
Editorial scrutiny: Look at the Dinter & Berger / A.Berger Team. Is it correct that these are two different Bergers? (Tropicos, IPNI). If not, search for the referenced name (type of Hereroa) and correct the authors. 
[bookmark: _Toc443998246]References
Open the Reference Bulk Editor and search for “*Mex*”
There are 2 duplicate entries and two article which are not properly atomised. Try to clean up this mess. 
[bookmark: _Ref443076898][bookmark: _Toc443998247]Using the specimen Bulk Editor
Go to the Bulk Editor for Specimen and Observations (Window -> Bulk Editor -> Specimen and Observations)
Search for all specimen with “*”. You should see the type specimens you entered before (section 2.5).
Click on one of the specimen and go to the Details View and fill the details like in the screenshots below.
[image: ]
In the Details view you will see available (empty) atomised data items for the specimen
The Title Cache field contains some of these data. Copy and paste them into the correct fields. 

Note: Do not click the lock icon of the title cache field before you are finished. Doing so would set the Title Cache to be automatically generated from the individual atomic fields.

When you are done click the lock icon of the Title Cache field.

[image: ]There are a number of additional specimen data items that can be added here. However, this is still the simplified view of specimen data, we will look at the full scope when we look at the Derivative Editor under section 7.2 below. 

[bookmark: _Toc443998248]TaxEditor: Advanced handling of specimen data – Imports and the Derivative Editor
[bookmark: _Toc443998249]Import of specimens via ABCD
ABCD (Access to Biological Collection Data) is TDWG standard. It is an XML schema defining data items used to describe specimens, field observations of species, and collections. It is largely compatible with but more extensive than the Darwin Core data standard with its various extensions. 
Open the Import interface in the menu under General-> Import-> CDM and select ABCD.
Under Import configuration check Add Media as MediaSpecimen and Map UnitID to accession number in addition to the already checked options. -> Next
Leave the botanical code as selected on the next page. -> Next
Under Configure import destinations leave the classification chooser empty (i.e. do nothing; a default classification will be created). -> Next
On the fourth page (Xml File) select the file Arenaria_ABCD_one_unit.xml and -> Finish. 
Let the Import routine do its work, it may take some time. In the end it will show you a report detailing what has happened (and if it has detected problems). 
Look at the taxon navigator for the classification and the taxa created from the import. 
Open Arenaria serpyllifolia L. subsp. serpyllifolia and have look at the Factual Data view. You will see the recently imported specimen attached to this taxon.
Now, if you search for '*' in the specimen Bulk Editor you should also find the recently imported specimen. Note: The Search can be filtered. Searching for '*Rheinland*' for example will only retrieve the imported specimen. 
[bookmark: _Toc443998250]Working with the Derivative Editor
Open the Derivative Editor: Window->Show View->Derivative Editor.
The top panel allows you to search specimens. The Title Cache corresponds to the specimen citation, don’t worry about the other items. Just enter * to see all specimens.
The derivative hierarchy of the specimen will be shown:
· The FieldUnit containing information about the collector and the gathering
· The PreservedSpecimen itself.
· A Specimen scan is visible because the link was part of the imported ABCD file (a preview is generated on-the-fly). 
Select the specimen scan in the hierarchy and have a look - the Details view will load a preview of the specimen scan.
[bookmark: _Toc443998251]Specimen duplicate - deduplication
We will import the same specimen (Hand 6047) again and pretend that it is an imported duplicate.
Select the specimen in the hierarchy and change the Collection to MEXU and the accession number to  PV1234567. ->Save
Repeat the import with the same file but uncheck the option „Ignore import of existing specimen“ and do not check „Add media as media specimen“.
Note: In the report you can see that no taxon or name was created but only the specimen. 
In the derivative hierarchy you will see two field units with the same title, each with a specimen.
Drag the one of the specimens to the other field unit.
Right-Click on the empty Field Unit -> Delete. Now we have only one field unit with two duplicate specimen.
[bookmark: _Toc443998252]Entering a specimen duplicate
Remember that in the Weberbauer 1353 specimen citation we did not enter the information that the holotype was a specimen in Berlin? 
Right click on the respective Field Unit -> New -> Specimen. Enter B as the collection and assign the specimen it to L. incachancana as the holotype. Don’t worry about the “destroyed” for the time being.
[bookmark: _Toc443998253]TaxEditor: Working with DNA and Sequences - The Alignment Editor
[bookmark: _Toc443998254]Import of DNA Data
Close all editors and import the file Arenaria_DNA_ABCD_one_existing_one_not.xml:
· Open the Import interface in the menu under General-> Import-> CDM and select ABCD.
· Open the Import interface in the menu under General-> Import-> CDM and select ABCD.
· Under Import configuration check Add Media as MediaSpecimen and Map UnitID to accession number in addition to the already checked options. -> Next
· Leave the botanical code as selected on the next page. -> Next
· Under Configure import destinations leave the classification chooser empty (i.e. do nothing; a default classification will be created). -> Next
· On the fourth page (Xml File) select (in your documents folder under Documents\EDIT-workshop\TaxEditor\) the file Arenaria_DNA_ABCD_one_existing_one_not.xml and -> Finish. 
Let the Import routine do its work (patience, please). In the end it will show you a report detailing what has happened (and if it has detected problems). Ignore the problems. 
Re-open the Derivative Editor and look at all “units”. There should be one new specimen and two new DNA Samples. 
[image: ]Have a look at the Detail view of the DNA Bank sample record.  
[bookmark: _Toc443998255]Adding and aligning sequences: The Alignment Editor
Right click on the DNA Bank sample record -> Add -> Consensus Sequence and Save
With this, you created a form for a consensus sequence (look at the Details view)
[image: ] 
Right click on the new entry -> Add -> Single Read
Click on the new derivative [image: ].
In the Details View, click the + under ReadChromatogram and enter the URI (web address) of a single read file. We provide example files on the web, so under Media URL enter http://ww2.biocase.org/svn/campanula/CAM385_GM312-petD_F.ab1
and, to add the backwards read
http://ww2.biocase.org/svn/campanula/CAM385_GM312-petD_R.ab1
Now right click on the new sequence entry [image: ] -> Edit Sequence. This opens the Alignment Editor.
In the menu, choose Alignment Editor -> (Re-) create Consensus sequence.
You can correct the alignment using the options in the menu and by directly editing the Consensus sequence. 
Save and close the Alignment Editor. In the Derivative Editor you can now see the Consensus sequence in the Details view and the two Single Reads as children of the Sequence in the derivation hierarchy. 
[If it doesn’t appear, try the Re-connect function in the Menu – there may be a remaining software problem.]
[bookmark: _Toc443998256][image: ]Xper2: Structured descriptive data and identification keys
The Xper2 software[footnoteRef:6] as we use it in the workshop is a standalone program which can be used independently (i.e. you can close the TaxEditor now). The database of the stand-alone version is compatible with the EDIT Platform and full integration of Xper2 as the descriptive data editor for the platform is the plan for the future (at the same time maintaining the possibility to use the stand-alone version). [6:  Xper2 is a long-standing development by our partners at the University Paris 6, Laboratoire Informatique et Systématique, UMR 7205 Institut de Systématique, Evolution, Biodiversité  - Prof. Régine Vignes Lebbe and her group. The following text was slightly adapted from scripts used by Régine Lebbe during an EDIT Platform workshop at the Caryophyllales 2015 conference in Berlin. ] 

With its intuitive interface, Xper² is aimed at professional taxonomists as well as naturalists who want to identify specimens using a ready­made application.
[bookmark: _Toc443998257]The software, terminology and workshop materials
Xper² is free of charge; download: http://lis­upmc.snv.jussieu.fr/lis/?q=en/resources/softwares/xper2
Written in Java, it is available on Windows™, Mac™, and Linux in French, English, Spanish and Chinese versions. Xper2 consists of three components: two java desktop applications (one used to manage the descriptive data contained in knowledge bases, and one used to perform interactive identification of the taxa described in these knowledge bases) and a java applet which allows users to perform interactive identifications online.
Descriptive data are structured. In Xper2 we use the following terminology :
· The described entities: taxa, specimens (“items”)
· The descriptors: properties used to describe the items (“characters”)
· The states or descriptor­states: possible values for each one of the descriptors (“character states”)
· The description: all states attributed to an item for each descriptor
· Groups: used to structure and to filter lists
In the Xper folder you will find a number of files and subdirectories:
· Xper2-Editor-2.3.2.exe: The Xper2 program.
· Guideline_Xper2.pdf: A graphic illustration of the program’s capabilities
· Folders Example and Cichorieae_full contain example knowledge-bases.
· Cichorieae_fullsdd.xml is an sdd-formatted export file used below as a complex example for key generation which was created for the Cichorieae exemplar group[footnoteRef:7] of the EDIT project.   [7:  Kilian N. Hand R. & Raab-Straube E. von; general editors) 2009+ (continuously updated):  Cichorieae Systematics Portal. Published at http://cichorieae.e-taxonomy.net/portal/] 

· Leaves: Some leaves images that can be used as examples (for copyright please refer to http://offene-naturfuehrer.de/web/H%C3%A4ufige_Laubb%C3%A4ume_nach_Bl%C3%A4ttern_bestimmen)

[bookmark: _Toc443998258][image: ]Tutorial: creating a first application
Open the Xper2 programme by double-clicking on the Xper2-Editor-2.3.2.exe file.
The menu gives access to the main functionalities of the program. 
This section proposes 10 simple steps to create your first application using Xper2.
[image: ](i) Start by creating a new knowledge base. 

In the menu, go to File -> New base.




[image: ](ii) Give a name to your new knowledge base


(iii) Edit Descriptors and States
To make the descriptions comparable, the data must be expressed in a structured format, using the same terminology. So you have to define the list of descriptors (or characters like “Leaf [shape]” and the values accepted (states ; i.e. “ovate”, “obovate”, “linear”, etc.) for each one.
You can use the images of leaves in your Xper folder to create a key, or use your own group to define a character matrix for a few species and construct the key (download and link illustrating images from the web).. 



[image: ]Click in a window with the right mouse button and choose New or Rename to label descriptors and states for each descriptor. 








[image: ](iv) Save the knowledge base
In the menu, select File -> Save to save under the current name, with 
File -> Save as... you can store it under a different name. 
Note: a knowledge base is stored in several files ; you can use 
File –> Zip base to store all the files in a single compressed file (.zip format).


[image: ](v) Adding text to define or comment on description elements
Click on the pencil button [image: ]   to add text on a selected element ((descriptor, state, group, or taxon). For example, add a comment on the descriptor “Shape of the nasarium”. 
Note that you can include HTML tags to format the text or to add hyperlinks.


[image: ](vi) Adding illustrations
Click on the button [image: ]  and select one or several pictures to illustrate the selected element (descriptor, state, group, or taxon).





[image: ](vii) Edit taxon list
In the menu, select Edit -> Edit taxa. Click on the Taxa window to add taxon names






(viii) Edit the description of a taxon
Select a taxon in the list. Select a descriptor. Check the respective state(s). 
If you don’t know, check Unknown description. 
[image: ]


[image: ](ix) Metadata
In the menu, select Edit -> Properties. 
Fill the different forms to describe the metadata (context, authors etc.) 






[image: ](x) Check the descriptions
In the menu, select Tools –> Check the base. 
The window displays information specially about the consistency of the descriptions (Data checking) and about the possibility or not to distinguish the different taxa (Taxa checking). If necessary, correct the descriptions or add new descriptors to separate the taxonomic descriptions. 






	[image: ]
	2016 EDIT Platform User Workshop



Save your sample knowledge base and close it. 
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[bookmark: _Toc443998259]A real-world example: Hymenophyllaceae of the Comores
Open the example knowledge base. Wait a moment for image processing. 
· Gain an overview of the taxa, descriptors and states present. 
· Try out the interactive identification. 
· Note that (in the stand-alone version) the nomenclature, taxonomy and factual data about the taxon are stored as free text. 
· Check the database - What’s wrong with the descriptor “Front dimorphism in shape”? 
· Look at the analytical functions (in the menu under Publish)
· Try the export functions – use “Test” as a filename (you can overwrite thumbnails and ignore the nexus error message; open the index.html in the web folder with Internet Explorer). 
[bookmark: _Toc443998260][image: ]Key generation
Apart from the interactive key provided by the Xper2 application itself, you can also generate a polytomous key from Xper2, using the LIS iKey+ webservice[footnoteRef:8].  [8:  Burguiere T., Causse F., Ung V. & Vignes-Lebbe R. 2013: IKey+: a new single-access key generation web service. Systematic Biology 62(1): 157-161. doi: 10.1093/sysbio/sys069. http://sysbio.oxfordjournals.org/content/62/1/157 ] 

Make sure you have exported your test.sdd.xml export file from the example knowledge base. 
In your web-browser, open http://www.identificationkey.fr/ikeyplus/ 
[image: ]Click on Upload your SDD file
Before you actually upload the file, look at the help links in the interface where the different options are described in an exemplary way. 
Upload your test.sdd.xml export file and/or use the Cichorieae example (Cichorieae.fullsdd.xml) for a more complex example. 


You could cut and paste the resulting txt- or html- formatted key into the TaxEditor, or use the Polytomous Key Editor to create a semi-structured key for your taxonomic treatment in the EDIT Platform for Cybertaxonomy. 
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